Windows 7 application sounds missing

Home Forums Windows Windows 7 application sounds missing

This topic contains 2 replies, has 2 voices, and was last updated by  HotDawg 3 years, 11 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #1026

    HotDawg
    Participant

    Here’s a problem I have pulled the last of my hair out over, and so far haven’t hit on the answer. It probably has a simple solution — but I haven’t solved it yet.

    My sound is no longer working — but only from applications. From Windows itself, it is just like it should be. This is in Windows 7 (Pro, 64 bit) and had been working until very recently.

    If I bring up Control Panel/sounds, and test any of the sounds there — they play just fine. Windows start and end sounds are heard when they should be. So, I have to assume the hardware, drivers and all are all OK. But, any sound that an application generates isn’t there. The newmail announcement is missing (altho the new mail flag pops up), streaming sound (like soundbytes) isn’t heard, and Utube videos are now silent movies.

    On the advice of RacerBob I had installed VLC, and thought maybe that was the problem. So I uninstalled that. Then, Media Player would complain about any sound file as being corrupt. With difficulty, I took Media Player off and put VLC back on. VLC will go thru the motions of playing a sound file, but nothing is heard.

    The onboard sound system is a Realtek system. All the options in their control panel seem OK. The sound system mixer, that has everything turned on and not muted, is all 100%. Clicking on the setting for speakers, or system sounds, produces a sound, all other applications do not.

    Checking the services that are running, there are a couple Windows Audio items, and they are both started.

    In the Speaker Properties/advanced the option to give applications exclusive control is checked, and that seems to be working. If VLC thinks it is playing a MP3 file, then sytem sounds are not heard.

    I’ve sure looked over all the ideas presented by Googling (including running some Fixit from Microsoft) and so far have not found the right answer.

    Any ideas?

    #1032

    Racerbob
    Participant

    HotDawg…I have been Googling and ran across this…

    http://answers.microsoft.com/en-us/windows/forum/windows_7-pictures/in-windows-7-no-sound-in-wmp-wmc-and-games-but-i/134127a5-4952-467b-8191-d94242d40d23

    Method 1.
    In some cases, you can work around the problem by disabling optional speaker effects that are collectively known as enhancements. If disabling speaker effects solves the problem, you might need to update your audio driver.

    To disable speaker audio enhancements.
    a. Open Sound by clicking the Start button, and then clicking Control Panel. In the search box, type sound, and then click Sound.
    b. On the Playback tab, click Speakers, and then click Properties.
    c. Click the Enhancements tab, and then select the Disable all enhancements check box.

    If you do not see an Enhancements tab in the Speakers Properties dialog box, those features are not available for your speakers and this procedure is not applicable to your computer.

    If disabling audio enhancements solves the audio problem you are experiencing, this typically indicates that your audio driver needs to be updated.
    If disabling audio enhancements solves the audio problem you are experiencing, check to see if an updated driver is available for your computer from the manufacturer’s website.
    Method 2.
    Perform the following steps and check if that helps.
    a. Click the Start Button, type “MMSYS.CPL” (without quotation marks) in the Start Search box and press Enter.
    b. On Playback tab, click the Speaker which is used currently and click Properties button.
    c. Switch to Advanced tab, uncheck the “Allow applications to take exclusive control of this device” option.
    d. If the Enhancements tab is available, click it. Check ‘Disable all sound effects”.
    e. In Setting section, Select None.
    f. Click Apply and click OK.

    #1077

    HotDawg
    Participant

    Thanks, Bob, for that link. I had run across it and it hadn’t solved my problem. But then, Google has turned up close to 7 trillion responses on how to fix this problem, most of them all different, and none were my answer.

    For anyone interested, this is what I ran across in my case. YMMV!

    What I finally did was a ‘system restore’ and that fixed things. But, what an education I got in the mean time. It seams that starting with Vista, Microsoft revised how sounds are handled. All applications are supposed to use DirectX as a gateway for them accessing the other end of the sound path (a sound endpoint), whether it are your speakers, headset, microphone, or whatever.

    On the other end of the sound path there are a couple services that run, somehow collect the sound, and turn it over to the process that you see as the volume control and mixer panel. System sounds seem to skip the DirectX part of this and talk directly to process that handles the volume controls.

    Most of the ‘fixes’ seem to center around updating the drivers for the sound card (or on-board hardware). At least in my case, if I plugged in a USB headset, that headset also did not get the missing sounds, so that sort of told me the problem was before the volume control application. Part of that has a bargraph where you can visually see the sound levels coming in, and they just weren’t there.

    In my Windows 7 I am running DirectX !!. I believe the OS comes originally with DirectX 10, but I don’t know when mine may have gotten updated. The diagnostics for it (DXdiag) passed with flying colors. Running SFC /SCANNOW did not replace any files, nor find fault with any. But, I wasn’t able to find a way to roll the DirectX back to 10, or even update what I have. So, as far as that part of it, what I have is what I got.

    Many of the suggested fixes involved getting Microsoft into the act. Their on-line suggestions fell into two groups. One, a troubleshooter for no sound seemed to be aimed at the people that forgot to plug in their speakers, or had them powered down, or had hit the MUTE. But, since system sounds were still working, that ruled that out. Then there is one or more FIXIT packages they will run for you. None of those accomplished anything, with one exception was with DirectX after I tried making some changes with it, and Mr. Fixit did his thing — but still no sound!

    There are some registry entries that control when the audio services run — but they seemed to be set the way they should be, and those services were running.

    My problems started when I picked up a game “Train Simulator” and installed it. At the time, I thought it was an updated version of the Microsoft Train Simulator, but found it was something different. About the time I installed that, not only did the sounds get upset, but a TV capture card I had wasn’t recognized any more. (Until I resolved things, I pulled that card out.) Also, a card reader I have, that normally shows as 4 different drives, developed a resistance to having working drivers installed. That connects internally to the USB bus, so was easy to temporarily remove, also.

    Doing a system restore to just before that game installation undid all that bad things I had been seeing. But, what had gotten gummed up, I really don’t know.

    I ran several different virus scans (including ones for rootkits) and nothing showed up there. I did not run the Tango — one of the requirements there is to dump all the restore points. In this case, that was my path back to a computer like I wanted.

    Sorry about the long discussion on this. Hopefully nobody else will run into the same situation, but possibly some of what I am posting here might help.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

Comments are closed.