Firefox Media

Home Forums Windows Firefox Media

This topic contains 14 replies, has 3 voices, and was last updated by kjvbible1611 kjvbible1611 4 years, 5 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #928
    kjvbible1611
    kjvbible1611
    Participant

    Firefox keeps opening media file links and plays them in the browser not my default media player.
    Help.
    Thank you,
    Gary

    #929
    Christian
    Christian
    Participant

    In the Applications tab there should be a long list with Content-Types on the left and Actions on the right. Each Action is a drop-down menu where you can have Firefox either save the file, open it with your choice of media player or ask you what to do. What happens to me is that whenever Firefox gets upgraded, these options seem to reset to their defaults.

    #930
    kjvbible1611
    kjvbible1611
    Participant

    Tried that, does not work, reset Win 7 defaults, player assoc. files etc. no work.
    Gary

    #931
    Christian
    Christian
    Participant

    I found this: http://support.mozilla.org/en-US/kb/set-how-firefox-handles-different-file-types

    Note: Some file types (e.g. MP3 audio) may have multiple content types that you will need to change. Also, when a plugin is available to handle a content type and you choose a different action for that type, Firefox will only take your chosen action when you access the type directly. For example, you may choose to open MP3 files with a media player application instead of using the plugin that is set to open it. In such cases, your chosen application will be used for file downloads but, when the content type is embedded inside a web page, Firefox will continue to use the plugin to handle the content type.

    It seems like you might have to change multiple Content-Type settings for some media. What happens if you disable whatever plugin Firefox is using to play the media?

    #932

    Racerbob
    Participant

    Gary, you did go to Options/Applications in Firefox itself ? All of my media formats show up there and I have them all set to play using VLC Media Player 2.0.6, which is my media player of choice.

    #934
    kjvbible1611
    kjvbible1611
    Participant

    yes.

    #935
    kjvbible1611
    kjvbible1611
    Participant

    if i save it as.. it opens in Jet Audio, if i just left click it it opens in FF browser’s media player or what ever it is.
    Gary

    #936
    kjvbible1611
    kjvbible1611
    Participant

    Christian how do i change multiple Content-Type settings for some media.& disable whatever plugin Firefox is using to play the media?
    Gary

    #937
    Christian
    Christian
    Participant

    In the General tab of Firefox’s preferences there should be a button called “Manage Add-ons”. When that opens there should be a Plugins section where you can enable/disable the various embedded media players.

    Which Content-Type setting you need to change depends on what type of media you’re dealing with. You said you can save the file right? When you do, what file extension does it have?

    #938
    kjvbible1611
    kjvbible1611
    Participant

    facebook video calling
    shockwave
    google update
    nvida 3d vision
    pdf-xchange viewer

    All plugins.
    saves as mp3

    #944
    Christian
    Christian
    Participant

    I’m not familiar with most of those plugins so I don’t know which ones if any are being used to play the mp3. I think at least one of those (assuming that’s all your plugins) has to be an mp3 player, otherwise Firefox would just prompt you to download the file.

    Can you link to a site that does this? That might help me see what is going on.

    In my copy of Firefox, there’s three mp3 related content-types, “MP3 Audio”, “MP3 Audio (streamed)”, and “MP3 ShoutCast playlist”. All three probably need to be set to “Save File” for it to work.

    #946
    kjvbible1611
    kjvbible1611
    Participant

    [URL=http://imageshack.us/photo/my-images/208/appo.jpg/][IMG]http://img208.imageshack.us/img208/7472/appo.jpg[/IMG][/URL]

    This is options applications FF21.

    Uploaded with [URL=http://imageshack.us]ImageShack.us[/URL]
    Gary

    • This reply was modified 4 years, 5 months ago by kjvbible1611 kjvbible1611.
    #947
    kjvbible1611
    kjvbible1611
    Participant

    http://jimfrenchproductions.com/zc137m/index.php?main_page=page&id=2&chapter=0&zenid=ep5nffbr9i6kerepa6ebrv93u6

    left click to listen, do not right click to save.
    i have no problem w/ saving it, i have a problem w/ just opening it.
    Gary

    #949
    Christian
    Christian
    Participant

    I think I found something here.

    Starting in Firefox 21 on Windows 7 and above, downloaded MP3 files (also MP4 files with the H.264 video codec and either AAC audio or MP3 audio codec) are also automatically played. Firefox Options -> Applications settings for those MIME types are ignored, unless you go to about:config and toggle the preference media.windows-media-foundation.enabled to false

    So try entering about:config in your URL/address bar, enter the key media.windows-media-foundation.enabled for the Filter, then, assuming that key shows up, change its status to false.

    #950
    kjvbible1611
    kjvbible1611
    Participant

    Got it, thank you.
    Gary

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.

Comments are closed.