Reply To: Windows 7 application sounds missing

Home Forums Windows Windows 7 application sounds missing Reply To: Windows 7 application sounds missing

#1077

HotDawg
Participant

Thanks, Bob, for that link. I had run across it and it hadn’t solved my problem. But then, Google has turned up close to 7 trillion responses on how to fix this problem, most of them all different, and none were my answer.

For anyone interested, this is what I ran across in my case. YMMV!

What I finally did was a ‘system restore’ and that fixed things. But, what an education I got in the mean time. It seams that starting with Vista, Microsoft revised how sounds are handled. All applications are supposed to use DirectX as a gateway for them accessing the other end of the sound path (a sound endpoint), whether it are your speakers, headset, microphone, or whatever.

On the other end of the sound path there are a couple services that run, somehow collect the sound, and turn it over to the process that you see as the volume control and mixer panel. System sounds seem to skip the DirectX part of this and talk directly to process that handles the volume controls.

Most of the ‘fixes’ seem to center around updating the drivers for the sound card (or on-board hardware). At least in my case, if I plugged in a USB headset, that headset also did not get the missing sounds, so that sort of told me the problem was before the volume control application. Part of that has a bargraph where you can visually see the sound levels coming in, and they just weren’t there.

In my Windows 7 I am running DirectX !!. I believe the OS comes originally with DirectX 10, but I don’t know when mine may have gotten updated. The diagnostics for it (DXdiag) passed with flying colors. Running SFC /SCANNOW did not replace any files, nor find fault with any. But, I wasn’t able to find a way to roll the DirectX back to 10, or even update what I have. So, as far as that part of it, what I have is what I got.

Many of the suggested fixes involved getting Microsoft into the act. Their on-line suggestions fell into two groups. One, a troubleshooter for no sound seemed to be aimed at the people that forgot to plug in their speakers, or had them powered down, or had hit the MUTE. But, since system sounds were still working, that ruled that out. Then there is one or more FIXIT packages they will run for you. None of those accomplished anything, with one exception was with DirectX after I tried making some changes with it, and Mr. Fixit did his thing — but still no sound!

There are some registry entries that control when the audio services run — but they seemed to be set the way they should be, and those services were running.

My problems started when I picked up a game “Train Simulator” and installed it. At the time, I thought it was an updated version of the Microsoft Train Simulator, but found it was something different. About the time I installed that, not only did the sounds get upset, but a TV capture card I had wasn’t recognized any more. (Until I resolved things, I pulled that card out.) Also, a card reader I have, that normally shows as 4 different drives, developed a resistance to having working drivers installed. That connects internally to the USB bus, so was easy to temporarily remove, also.

Doing a system restore to just before that game installation undid all that bad things I had been seeing. But, what had gotten gummed up, I really don’t know.

I ran several different virus scans (including ones for rootkits) and nothing showed up there. I did not run the Tango — one of the requirements there is to dump all the restore points. In this case, that was my path back to a computer like I wanted.

Sorry about the long discussion on this. Hopefully nobody else will run into the same situation, but possibly some of what I am posting here might help.