Reply To: My Router Runs Linux

Home Forums Linux My Router Runs Linux Reply To: My Router Runs Linux

#591
Christian
Christian
Participant

Believe me HotDawg, that was first on my mind. Several posts I read said it would only be on the LAN side. As soon as I gained access I quickly checked and couldn’t access it from the WAN side.

The telnet interface isn’t very useful on the WPN824N. People with other consumer Netgear routers were complaining that their settings wouldn’t survive a reboot. Mine only lasted minutes! I think I found the script that “refreshes” the firewall. I could add my firewall rules there except the system has no editor. I’d have to do something fancy with splitting the file in order to add a line.

The reason I was messing with all this was my new apartment doesn’t have phone jacks where I need them to be. My desktop, server and voip gateway need to go on one side of the room but the AT&T modem needs to be plugged into the phone jack on the other side. I can’t run a wire between them so I added a wifi card to the server. I’ve been messing with two options. What it looks like I’ll be doing will be bridging the server’s wireless and wired cards in order to provide access to the wired clients on that side. What I was hoping to do was simply route from the wired subnet to the wireless. That worked fine internally but the wired machines couldn’t get internet access. Using telnet I was able to verify the subnet that the router is on is the only one getting NATed. Packets from the wired subnet pass right through to the WAN and since they’re private IPs I don’t expect they’ll be coming back anytime soon. Using telnet I was able to fix this temporarily and watched with amazement as the whole system worked the way I wanted it too. Unfortunately that was short lived. Now I need to look into creating the bridge. Wish me luck.