Reply To: Resource Monitor won't start in Win 7

Home Forums Windows Resource Monitor won't start in Win 7 Reply To: Resource Monitor won't start in Win 7

#2113

HotDawg
Participant

This probably will end up longer than what is appropriate for here — but I’ll try and make it as complete as I can so that somewhere it might ring a bell with someone as to what hit me.

The original reply by Nick suggested a virus, and I was suspicious of that from early on. And, early in this game I ran the Security Tango and it didn’t catch anything. I have also since run a about every anti-virus and anti-malware program that has a free version. One program did say I had the Fun Mood toolbar — which I wasn’t aware of — I guess that only hits IE, which I avoid as much as possible.

Let’s go back a little. I run a dual-boot system, with Windows 7 Pro, 64-bit being the OS of choice. I also had Windoze 8 available, Ubuntu, and a couple other operating systems. My normal antivirus protection is the free version of Avast, which I think is good.

Avast popped up a little window and told me I had some unwanted toolbar, some ‘grime’ that was slowing down the boot process, and files on the HD they could delete. At that point I did gave the OK to fix things, apparently they took off the toolbar, but wanted me to upgrade to a paid version for the rest. Avast provides a boot-time scan where they scan for malware before the OS takes over. I set that up, and went to bed.

The next morning, the computer was up, and with a message it had been restarted by Microsoft because of some updates. That is when the fun started!

The first thing I noticed was my desktop gadgets were gone. When I brought up Firefox, and opened a second tab — I was presented with a Google search page rather than the default multiple links to recently used sites. When I brought up Chrome, opening a tab also gave me the Google search page. For Firefox I found where you can specify an address for when you open a tab — and that had the Google.com address, and in bold, indicating it wasn’t the default anymore. I set that back to the default, and that problem was solved. I did check my HOST file to make sure that Google.com wasn’t pointing to somewhere strange.

Then, more things started to show up. I had no sound from running programs. It was there for system sounds — but things like new mail notifications were silent. Once before I had that, and a system restore had fixed it. But, for some reason my system restore had been turned off. I found that the non-standard letter assignments for the various partitions (like my optical drive is normally X:) had gone back to defaults. My network printer was no longer accessible. Both for printing, and to log into it’s web page. Windows update no longer would install any updates. The errors it gave were generally ‘permission denied’ type things.

Needless to say, with all these things happening, I assumed I had been hit with some malware. I booted into the Windows 8 side of things, and ran a complete virus scan from there. That has AVG on it for virus protection, and sometimes AVG will find things that Avast misses. And, running it from there is like having my other HD mounted as a slave. When that didn’t turn up anything, I ran the Security Tango. Again, no problems identified.

I had a backup that I had made back in December, so using Ubuntu (rsync) I made a complete backup of my present Win 7 C: drive, and then copied back in the all the files from the December backup that did not match. Surprisingly, there were no files in the Windows tree that were replaced. However, that seemed to restore the normal operation of the system.

At that point, the Resource Monitor was working. Just when it failed, I am not sure — but it was after this point. I had in the back of my mind that maybe there were some malware hiding somewhere that the restore from December had not overwritten, so I ran the Security Tango again. Still no hits!

When Nick suggested a possible virus, I started running all kinds of virus check and checks for rootkits. Some claim that with a 64 bit operating system you don’t need to worry about rootkits — but at this point I was being over-cautious. And, I ran the full virus scans from both the Windows 7 installation, and the Windows 8. Guess I found one good use for Windows 8!

I think there were something like 15 different virus, malware, and rootkit scanners that I tried. The only one that gave me fits was Comodo, and I had real problems there. But, that would be a different story.

I decided to reinstall the Windows 7 over itself. That turned into a comedy of errors because of the way my Windows installation had evolved. To make a long story a little shorter, I downloaded a Windows 7 installation DVD from Microsoft and was able to use that.

At this point, everything seems to be working OK. That solved the Resource Monitor problem. Also set me up for some 243 updates from Microsoft!

In this whole process, one thing I did learn, installing IE 11 is what kills the desktop gadgets. Uninstalling it restores them.

I run with 16 GB of RAM. I have turned off the paging file, since that can be one place for things to hide. Likewise I have disabled the hibernate, so I don’t have the hibernate file for things to sneak into. I do use sleep mode at times, and it doesn’t create any places for things to hide.

Now, if anyone has any ideas on what I might have gotten hit with or what to use to find it, I would sure like to know.